System Requirements

Supported browsers include Firefox, Chrome and Safari.

While the majority of features will work with other browsers, we can only guarantee full compatibility for the browsers mentioned above.

If you are using one of the supported browsers and are experiencing problems, we encourage you to upgrade to the latest version. If you still experience problems after upgrading, please make sure that your browser is set to accept cookies. Also, make sure the following browser settings are enabled:

  • JavaScript must be enabled.
  • Popup blockers must be disabled.

If your browser has a section for trusted sites, please enter these URL:

  • https://sswforms.es.its.nyu.edu

You will need Adobe Reader 6.0 or higher to download, view and print PDF files. While PDF files should work with most other PDF viewers, we can only guarantee full compatibility and support for Adobe Reader 6.0 or higher.

If your email offers a whitelist, please add the following address:

  • no-reply@nyu.edu

Please record your password in a safe place since you will need both your User Name and password to access your application in the future.

For security reasons, we recommend that you logout of the online application after each session.